万年素人からHackerへの道

万年素人がHackerになれるまで殴り書きするぜ。

  • ・資産運用おすすめ
    10万円は1000円くらい利益
    資産運用ブログ アセマネ
    • ・寄付お願いします
      YENTEN:YYzNPzdsZWqr5THWAdMrKDj7GT8ietDc2W
      BitZenny:ZfpUbVya8MWQkjjGJMjA7P9pPkqaLnwPWH
      c0ban:8KG95GXdEquNpPW8xJAJf7nn5kbimQ5wj1
      Skycoin:KMqcn7x8REwwzMHPi9fV9fbNwdofYAWKRo

    Flutterのflutter.minSdkVersionとの戦い

    これがうぜー。

     /Users/shinriyo/development/flutter_apps/joyreco/android/app/build.gradle:                    │
    │ android {                                                                                     │
    │   defaultConfig {                                                                             │
    │     minSdkVersion 19                                                                          │
    │   }                                                                                           │
    │ }                                                                                             │
    │        
            // You can update the following values to match your application needs.
            // For more information, see: https://docs.flutter.dev/deployment/android#reviewing-the-build-configuration.
            minSdkVersion flutter.minSdkVersion
            targetSdkVersion flutter.targetSdkVersion

    flutter.minSdkVersion を直接書き換えるのも変。

    android/local.properties

    flutter.minSdkVersion=26

    って追加したらいけるっておもったら行けない。 ここに書いた場合は、

    minSdkVersion localProperties.getProperty('flutter.minSdkVersion').toInteger()

    みたいに書かないと android/local.propertiesファイルが呼ばれないっぽい・・・。 ちなみに.toInteger()はつけなくてもいいらしい。

    元々flutter.minSdkVersionって書いてたのを書き換えるのもなんか流儀に反してるような気が・・・。

    この記事を参考にした。 FlutterでAndroidのbuildをしたらエラーが出た!

    記事では、/Users/hashimotojunichi/Development/flutter/packages/flutter_tools/gradle

    僕は fvm 使っているので、 /Users/shinriyo/fvm/versions/3.0.5の中にある 3.0.5/flutter/に相当するので、

    /Users/shinriyo/fvm/versions/3.0.5/packages/flutter_tools/gradle/flutter.gradle にあった。

        //static int minSdkVersion = 16
        static int minSdkVersion = 21

    に書き換えたらOK!I