万年素人からHackerへの道

万年素人がHackerになれるまで殴り書きするぜ。

  • ・資産運用おすすめ
    10万円は1000円くらい利益
    • ・寄付お願いします
      YENTEN:YYzNPzdsZWqr5THWAdMrKDj7GT8ietDc2W
      BitZenny:ZfpUbVya8MWQkjjGJMjA7P9pPkqaLnwPWH
      c0ban:8KG95GXdEquNpPW8xJAJf7nn5kbimQ5wj1
      Skycoin:KMqcn7x8REwwzMHPi9fV9fbNwdofYAWKRo

    Because アプリ名 depends on プラグイン名の対策エラー対策

    Androidのリリースビルドしようと、

    flutter build apk

    するときに

    Running "flutter packages get" in cafemaster...
    The current Dart SDK version is 2.1.0-dev.9.4.flutter-f9ebf21297.
    
    Because shared_preferences 0.3.3 requires SDK version >=1.8.0 <2.0.0 and no versions of shared_preferences match >0.3.3 <0.4.0, shared_preferences ^0.3.3 is forbidden.
    So, because cafemaster depends on shared_preferences ^0.3.3, version solving failed.
    
    pub get failed (1)

    これ系のエラー出たら。 とりあえず該当プラグイン

    Page 1 | Top Dart packages

    このサイトでプラグインを検索して 該当プラグインの「Installing」を開いてpubspec.yamlを真似ると治るかも?