万年素人からHackerへの道

万年素人がHackerになれるまで殴り書きするぜ。

CommonLispのWebサーバ Wookieを使う

Documentation | Wookie

まずこれが必須みたい。

libuvのインストール

brew install --HEAD libuv

libuvを入れずにWookieをインストール時のエラー

* (ql:quickload :wookie)
To load "wookie":
  Load 1 ASDF system:
    wookie
; Loading "wookie"
..
debugger invoked on a LOAD-FOREIGN-LIBRARY-ERROR in thread
#<THREAD "main thread" RUNNING {1001F1EAB3}>:
  Unable to load any of the alternatives:
   ("libuv.dylib")

になってしまうからね。

Wookieのインストール

(ql:quickload :wookie)